A vulnerability, which was classified as problematic, has been found in argocd up to 2.7.14/2.8.7/2.9.3/2.10-rc1. This issue affects some unknown processing of the component Setting Handler. The manipulation leads to cross-site request forgery.

The identification of this vulnerability is CVE-2024-22424. The attack may be initiated remotely. There is no exploit available.

It is recommended to upgrade the affected component.